Trade Execution Issues
Incident Report for Drive Markets
Resolved
The incident has been resolved and trading has now resumed. We are taking the necessary steps to prevent this from happening again.
Posted 4 months ago. Jul 09, 2019 - 15:33 UTC
Update
Our partners are continuing a thorough analysis of the issue at hand and will continue the investigation until a cause has been found. We will communicate any progress as soon as it is passed onto us or will update the situation ourselves within the next 2 hours.
Posted 4 months ago. Jul 08, 2019 - 17:26 UTC
Investigating
We are currently experiencing large volumes of trades failing to execute due to a fault with one of our partners. We are working closely with them to identify the issue and will be delivering a fix as soon as possible.
Posted 4 months ago. Jul 07, 2019 - 00:00 UTC