BSVUSD trading unavailable
Incident Report for Drive Markets
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 24, 2019 - 19:32 UTC
Investigating
BSVUSD trading is currently unavailable and showing off quotes while we investigate the issue. All other symbols remain operational.
Posted 2 months ago. Aug 24, 2019 - 16:39 UTC